Cómo sumar todos los números pares en un rango

Contenidos
  1. Ejemplo
  2. Fórmula genérica
  3. Que hace
  4. Cómo funciona

Ejemplo

{=SUMA(B3:B10*(MOD(B3:B10,2)=0))}Descargar archivo de ejemplo

Fórmula genérica

{=SUMA(Rango*(MOD(Rango,2)=0))}

Nota : Esta es una fórmula de matriz . No escriba loscorchetes {} . Mantenga presionadas las teclas Ctrl + Shift y luego presione Enter mientras está en el modo de edición para crear una fórmula de matriz .

Rango : este es el rango de valores del que le gustaría sumar todos los números pares.

Que hace

Esta fórmula sumará todos los números pares de un rango de valores dado. Un número par se define como cualquier número que tiene un resto de 0 cuando se divide por 2.

Cómo funciona

La función MOD devuelve el resto de un número al dividirlo por otro número. Por ejemplo , MOD(7,2) devolverá 1 ya que el resto de 7 dividido por 2 es 1. Usamos la función MOD para probar si un número es par. Un número será par si y solo si el resto de la división por 2 es igual a 0. En otras palabras, N es par si y solo si MOD(N,2)=0 .

MOD(Rango,2)=0 creará una matriz de valores booleanos donde VERDADERO significará que el número es par y FALSO significará que el número no es par. Luego, multiplicamos esta matriz booleana por el rango para obtener una matriz donde cada valor es un valor par del rango o un 0 . Esto se debe a que N*VERDADERO es igual a N y N*FALSO es igual a 0 para cualquier número N.

En nuestro ejemplo , MOD({1.36;-2;2;9;10;7;1.33;8},2)=0 dará como resultado la siguiente matriz booleana.

{FALSO;VERDADERO;VERDADERO;FALSO;VERDADERO;FALSO;FALSO;VERDADERO}

Cuando multiplicamos esto por Range obtenemos {0;-2;2;0;10;0;0;8} . Entonces SUM({0;-2;2;0;10;0;0;8}) da como resultado 18 , que es la suma de todos los números pares en nuestro rango de valores.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Subir

Utilizamos cookies para asegurar que damos la mejor experiencia al usuario en nuestra web. Si sigues utilizando este sitio asumiremos que estás de acuerdo.